Menu

文档

GAUSS-52200 – GAUSS-52299

GAUSS-52200: “Unable to import module: %s.”

SQLSTATE: 无

错误原因:采用系统默认python执行工具,导致导入包错:缺少python依赖的库。

解决办法:使用安装包中自带的python执行工具,即进入安装包解压的目录,使用“./工具名”方式来执行命令。

以执行前置为例:

进入到工具脚本存放目录下:

cd /opt/software/gaussdb/script

使用./gs_preinstall 执行前置:

./gs_preinstall -U omm -G dbgrp -X /opt/software/gaussdb/clusterconfig.xml --alarm-type=5 --root-passwd=Gauss_234

GAUSS-52201: “The current python version %s is not supported.”

SQLSTATE: 无

错误原因:操作系统默认的Python不是2.6.X或2.7.X。

解决办法:替换操作系统默认的Python编译器版本。

本文档遵循知识共享许可协议CC 4.0 (http://creativecommons.org/Licenses/by/4.0/)。